This project is read-only.

imagepatcher package.xml

Apr 29, 2011 at 6:23 PM

My first attempts at using imagepatcher and I'm running into issues with an error

Get-Content : Cannot find path 'C:\imagepatcher\package.xml' because it does not exist.
At C:\imagepatcher\imagepatcher.ps1:371 char:14
+ $x = [xml](gc <<<<  $scriptpath"\package.xml")
    + CategoryInfo          : ObjectNotFound: (C:\imagepatcher\package.xml:String) [Get-Con
   n
    + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.GetContentCommand

 

followed by

Write-Debug : Cannot bind argument to parameter 'Message' because it is null.
At C:\imagepatcher\imagepatcher.ps1:391 char:24
+             write-debug <<<<  $imageindex.name
    + CategoryInfo          : InvalidData: (:) [Write-Debug], ParameterBindingValidationE
    + FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,Microsoft.Po
   ommand

New-Item : Item with specified name C:\imagepatcher\mount\ already exists.
At C:\imagepatcher\imagepatcher.ps1:401 char:21
+             New-Item <<<<  -path $mountdir"\"$imagendx -type directory | out-null
    + CategoryInfo          : ResourceExists: (C:\imagepatcher\mount\:String) [New-Item],
    + FullyQualifiedErrorId : DirectoryExist,Microsoft.PowerShell.Commands.NewItemCommand

 

any clues?

Jul 1, 2011 at 4:27 PM

try running this command from the dism /Cleanup-Wim Deployment Tools Command Prompt

 

where did you put the files?

Jul 14, 2011 at 3:25 PM

i had the files in a folder on the root of c.  i believe i found the issue having a problem not having powershell fully enabled to run scripts.  i removed all restrictions on a system and the patch ran fine.

a question...is this applying critical only? if so can i modify to include important as well?